Clearinghouse Delays impacting Claims and Remits

Incident Report for Fusion by Ensora Health

Resolved

This incident has been resolved.
Posted Jul 20, 2026 - 10:55 EDT

Monitoring

Earlier this morning Fusion experienced a delay in communications with our clearinghouse which may have impacted claim submissions and receiving remits. The backlog is actively being processed and will catch up throughout the day.

We are actively monitoring to ensure no further delays.
Posted Jul 20, 2026 - 10:29 EDT
This incident affected: Fusion by Ensora Health and Billing (Claim Submission, Electronic Remits).