Claim Submission, ERA responses, and Eligibility Requests Outage - Change Health Care
Incident Report for Fusion Web Clinic
Monitoring
We recognize the impact the recent Change Healthcare cyberattack may have on your business, and our team continues to work on rerouting claims to alternatives. At this time, the Claim.MD clearinghouse has not provided Therapy Brands with an update other than they are working on restoring all connections. They continue to send out updated payer lists. Please refer to https://www.claim.md/payer_list.html for more information.
Posted Apr 15, 2024 - 13:30 EDT
Update
We have been informed that Change Health Care, used by clearinghouses to connect to over 500 payers, is experiencing a network interruption related to a cyber security event. Change Health Care is reporting updates on this issue here: https://status.changehealthcare.com/incidents/hqpjz25fn3n7

Claim submission, ERA responses, and eligibility requests for these payers will be affected. The clearinghouse will hold all further claim submissions until additional information is available. Claims submitted recently to one of these payers may receive alerts for missing responses or ERA. The clearinghouse does not recommend resubmitting these at this time.

We apologize for any inconvenience this may have caused. We will keep you updated as more information becomes available to us.
Posted Feb 22, 2024 - 09:20 EST
Identified
We have been informed that Change Health Care, used by clearinghouses to connect to over 500 payers, is experiencing a network interruption related to a cyber security event. Change Health Care is reporting updates on this issue here: https://status.changehealthcare.com/incidents/hqpjz25fn3n7

Claim submission, ERA responses, and eligibility requests for these payers will be affected. The clearinghouse will hold all further claim submissions until additional information is available. Claims submitted recently to one of these payers may receive alerts for missing responses or ERA. The clearinghouse does not recommend resubmitting these at this time.

We apologize for any inconvenience this may have caused. We will keep you updated as more information becomes available to us.
Posted Feb 22, 2024 - 09:20 EST
This incident affects: Billing (Claim Submission, Electronic Remits).